You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

68 lines
2.2 KiB

7 years ago
{
"name": "@doodle3d/doodle3d-slicer",
5 years ago
"version": "0.0.18",
"description": "JavaScript gcode slicer, Intended to use with the Doodle3D WiFi-Box # Usage",
"main": "lib/index.js",
"module": "module/index.js",
"esnext": "src/index.js",
"scripts": {
5 years ago
"start": "webpack-dev-server -w",
5 years ago
"prepare": "npm run build",
"build": "npm run build:main && npm run build:main:settings && npm run build:module && npm run build:module:settings ",
"build:main": "BABEL_ENV=main babel src -s -d lib",
"build:module": "BABEL_ENV=module babel src -s -d module",
"build:main:settings": "cp -r src/settings lib",
"build:module:settings": "cp -r src/settings module"
},
"dependencies": {
"@doodle3d/clipper-js": "^1.0.7",
"babel-plugin-transform-class-properties": "^6.24.1",
"file-saver": "^1.3.3",
"lodash": "^4.17.4",
5 years ago
"material-ui": "^0.19.4",
"proptypes": "^1.1.0",
5 years ago
"react": "^16.0.0",
"react-dom": "^16.0.0",
"react-jss": "^7.2.0",
"react-resize-detector": "^1.1.0",
"three": "^0.88.0"
},
6 years ago
"devDependencies": {
5 years ago
"@doodle3d/doodle3d-core": "github:doodle3d/doodle3d-core",
"babel-cli": "6.24.1",
"babel-loader": "7.0.0",
"babel-plugin-transform-es2015-classes": "^6.24.1",
"babel-plugin-transform-object-rest-spread": "^6.26.0",
"babel-plugin-transform-runtime": "^6.23.0",
"babel-polyfill": "^6.26.0",
"babel-preset-env": "^1.6.1",
5 years ago
"babel-preset-es2015": "6.24.1",
"babel-preset-react": "^6.24.1",
"babel-preset-stage-0": "^6.24.1",
5 years ago
"babel-runtime": "^6.26.0",
"html-webpack-plugin": "^2.29.0",
5 years ago
"html-webpack-template": "^6.0.2",
"imports-loader": "^0.7.1",
"material-ui": "^0.19.4",
"normalize-jss": "^4.0.0",
"raw-loader": "^0.5.1",
5 years ago
"react-tap-event-plugin": "^3.0.2",
"url-loader": "^0.5.9",
"webpack": "^3.3.0",
"webpack-dev-server": "^2.5.1",
"worker-loader": "^0.8.1",
"yml-loader": "^2.1.0"
},
"repository": {
"type": "git",
"url": "git+https://github.com/Doodle3D/Doodle3D-Slicer.git"
},
"author": "",
"license": "UNLICENSED",
"private": true,
"bugs": {
"url": "https://github.com/Doodle3D/Doodle3D-Slicer/issues"
},
"homepage": "https://github.com/Doodle3D/Doodle3D-Slicer#readme"
7 years ago
}